summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakub 'Eremiell' Marek2022-09-30 16:23:54 +0200
committerJakub 'Eremiell' Marek2022-09-30 16:23:54 +0200
commite12bc15133a56e4dfd23727385c9fa80e7953e75 (patch)
tree70d742400c9b117e6fa2fc4db7ff220f85820f08 /PKGBUILD
parent92d54fe35f21c2a25221418835f7dcc8a304c2ab (diff)
downloadaur-e12bc15133a56e4dfd23727385c9fa80e7953e75.tar.gz
🔖 Update package, version 10.0.20-1
* Upstream version update * Forums support * Various bugfixes * See upstream changelog for details
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 021263adf72c..696c9b186473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.19
+pkgver=10.0.20
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
url="https://dpp.dev/"
license=('Apache')
depends=('gcc-libs' 'openssl' 'zlib' 'opus' 'libsodium' 'nlohmann-json')
-makedepends=('cmake')
+makedepends=('cmake' 'pkgconf')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('1126d927540715f7405d5bc33bd7ae54314431c7b1545bb5e886addfc547cf51')
+sha256sums=('c4a7481c714c27d9c1411c668212e433fa5f6631a933676269c866295bd4ef73')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -24,7 +24,6 @@ prepare() {
mv "cmake/libdpp-config.cmake" "cmake/dpp-config.cmake"
sed -i -E "s/^.*dpp\/nlohmann.*$//" "library/CMakeLists.txt"
rm -rf "include/dpp/nlohmann"
- sed -i -E -e "s/std::map<event_handle, std::function<void\(const T\)>> coroutine_container;/std::map<event_handle, std::function<dpp::task(T)>> coroutine_container;\n#else\n \/**\n * @brief Dummy container to keep the struct size same\n *\/\n std::map<event_handle, std::function<void(T)>> dummy_container;/" -e "s/event_handle attach\(std::function<dpp::task\(const T&\)> func\) \{/event_handle co_attach(std::function<dpp::task(T)> func) {/" "include/dpp/cluster.h"
}
build() {