summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYiyao Yu2019-06-22 12:36:17 +0800
committerYiyao Yu2019-06-22 12:40:29 +0800
commitf37d8b03eeda1e211ce1c64c40941193b1c33403 (patch)
tree94ee601e9e9e95fc61bb8a910873ad1902361f6e /PKGBUILD
downloadaur-f37d8b03eeda1e211ce1c64c40941193b1c33403.tar.gz
1.3-1: Initial upload to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7319124bb16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Yiyao Yu <yuydevel at protonmail com>
+
+_pkgname=dptfxtract
+pkgname="${_pkgname}-bin"
+pkgver=1.3
+pkgrel=1
+pkgdesc="Intel's Linux DPTF Extract Utility for generating thermald's thermal_conf.xml"
+arch=('x86_64')
+url="https://github.com/intel/dptfxtract"
+license=('custom:Binary License')
+provides=('dptfxtract')
+conflicts=('dptfxtract')
+depends=('thermald')
+source=("https://github.com/intel/dptfxtract/archive/v1.3.tar.gz")
+sha256sums=('c8efa83a15072a934f8288a19435d9f068ac2f6a1c7e6abbc4e986e199119f26')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -Dm 755 'dptfxtract' "${pkgdir}/usr/bin/dptfxtract"
+ install -Dm 644 'COPYING' "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+