summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Hafner2023-10-09 17:34:41 +0200
committerFabian Hafner2023-10-09 17:34:41 +0200
commit027d77157b81e627735a848a37f43a0226bfa761 (patch)
tree7dc2b39913c73cf5165ebb73234b1f1e46de5cc1 /PKGBUILD
parent8360f79a242420188c734088657d4d6dd34e50bb (diff)
downloadaur-dr14_t.meter-git.tar.gz
pep517 and makedepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7089972e12b0..510d8140738f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://github.com/simon-r/dr14_t.meter"
license=('GPL3')
depends=('python' 'flac' 'lame' 'faad2' 'ffmpeg' 'vorbis-tools' 'python-numpy' 'python-mutagen')
optdepends=('python-matplotlib: plot support for python' 'python-scipy: dyn compression')
-makedepends=('git')
+makedepends=('git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}" "dr14_tmeter")
source=('dr14_t.meter::git+https://github.com/simon-r/dr14_t.meter.git#branch=master')
@@ -22,10 +22,10 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/${pkgname%-git}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}