summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorallddd2023-08-08 19:07:17 +0200
committerallddd2023-08-08 19:07:17 +0200
commit7131267261460ae08348ccab7329414b835e8549 (patch)
tree849708d1572a08e38b503b18c85042fc891cbd55 /PKGBUILD
downloadaur-7131267261460ae08348ccab7329414b835e8549.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4af9499c009b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Allddd <allddd (at) proton (dot) me>
+pkgname=dracula-rofi-git
+pkgver=r27.05618ac
+pkgrel=1
+pkgdesc='Dark theme for Rofi'
+arch=('any')
+url='https://draculatheme.com/rofi'
+license=('MIT')
+makedepends=('git')
+optdepends=('rofi')
+source=("${pkgname}::git+https://github.com/dracula/rofi.git")
+sha256sums=('SKIP')
+install=${pkgname}.install
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${pkgname}
+ list=$(find ./theme/ -type f -name '*.rasi')
+ for conf in ${list}; do
+ num=$(printf ${conf} | sed 's/[^0-9]*//g')
+ install -Dm644 "${conf}" "${pkgdir}/usr/share/rofi/themes/dracula${num}.rasi"
+ done
+}