summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2019-10-14 15:36:31 +0200
committerPhilip Goto2019-10-14 15:36:31 +0200
commit418a2953935b7e623baf2e2b0e68b13cd6f2ac46 (patch)
tree4bae353f6fc37137eb62b7300bbd80c31df60d0f /PKGBUILD
parent455a95900d6dc36782dc5cb96a0e748e9fa4b201 (diff)
downloadaur-drawing-git.tar.gz
Update PKGBUILD to match community package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a55309ebee9..28d4249e729c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=drawing-git
-pkgver=0.2.r4.g3f49a0e
+pkgver=0.4.1.r116.g75f8140
pkgrel=1
pkgdesc="Drawing application for the GNOME desktop"
url="https://github.com/maoschanz/drawing"
arch=(any)
-license=(GPL)
-depends=(gtk3 python)
-makedepends=(git meson python)
-provides=(drawing com.github.maoschanz.Drawing)
+license=(GPL3)
+depends=(gtk3 python-cairo python-gobject)
+makedepends=(git meson)
conflicts=(drawing)
source=("git+https://github.com/maoschanz/drawing.git")
sha256sums=(SKIP)
pkgver() {
cd drawing
- git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -24,9 +23,9 @@ build() {
ninja -C build
}
-#check() {
-# meson test -C build
-#}
+check() {
+ meson test -C build
+}
package() {
DESTDIR="$pkgdir" meson install -C build