summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2020-04-21 22:16:30 +0300
committerViktor Drobot2020-04-21 22:16:30 +0300
commit4bfded92ab8747e55c5a69c3e4860d9cf4690492 (patch)
tree25d5a985f802c0eb4e7cc748f050c6fafcb22147 /PKGBUILD
downloadaur-4bfded92ab8747e55c5a69c3e4860d9cf4690492.tar.gz
First release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7df83007a82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=dream
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="A software radio for AM and Digital Radio Mondiale (DRM)"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/drm"
+license=(GPL2)
+depends=(fftw opus libsndfile speexdsp hamlib libpulse qwt qt5-webkit qt5-svg qt5-base)
+makedepends=(gcc)
+source=("https://sourceforge.net/projects/drm/files/dream/${pkgver}/${pkgname}-${pkgver}-svn808.tar.gz")
+md5sums=('4745a4f03216bc3afda077398d0e5d3b')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ qmake-qt5 dream.pro
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ make INSTALL_ROOT=${pkgdir} install
+}