summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2024-03-05 21:10:03 +0100
committerMichal Wojdyla2024-03-05 21:10:03 +0100
commit4f59c690f9faf57edea288ff33015ab2711a33cd (patch)
treef5225b9cccc3dae6239062d5e578317e5f4e3911 /PKGBUILD
parent60db60e350bb011de9e7189f9646a6ca5f485b96 (diff)
downloadaur-dreampie.tar.gz
usr latest commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b06344dda22..d1e9a41e6cd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
+# Contributor: Michal Wojdyla < micwoj9292 at gmail dot com >
# Contributor: Kyle Keen <keenerd@gmail.com>
# transition pkgbuild while figuring out python2/python3 versions
pkgname=dreampie
-pkgver=1.2.1
+pkgver=1.3.0.20220116
+_commit=f615e9c63380d5987a820025fbb9dfe28ab96897
pkgrel=1
pkgdesc="A Python shell which is designed to be reliable and fun."
arch=('any')
@@ -11,19 +13,19 @@ url="https://github.com/noamraph/dreampie"
license=('GPL')
depends=('pygtksourceview2')
optdepends=('python2-matplotlib: for interactive plotting')
-source=($pkgname-$pkgver.tar.gz::https://github.com/noamraph/dreampie/tarball/$pkgver)
-md5sums=('6d745ce46624ebce91e2aac67ebbfbf1')
+source=($pkgname-$pkgver.zip::https://github.com/noamraph/dreampie/archive/$_commit.zip)
+md5sums=('ff8223d17115811f05661716c71f95ca')
build() {
# git sha in srcdir
- cd "$srcdir/noamraph-dreampie"-*
+ cd "$srcdir/dreampie"-$_commit
# build won't work with py3
# but the later install is fine
python2 setup.py build
}
package() {
- cd "$srcdir/noamraph-dreampie"-*
+ cd "$srcdir/dreampie"-$_commit
#if which python3; then
# python3 setup.py install --prefix=/usr --root="$pkgdir"
# mv "$pkgdir/usr/bin/dreampie" "$pkgdir/usr/bin/dreampie-py3"