summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 14:10:51 +0200
committerJerome Leclanche2015-06-09 14:10:51 +0200
commit65484b888f5ac41007cda20fba75c41f3072a139 (patch)
tree5b9c6be2586f7dc68e1b0fa32d33a722eebf7efb /PKGBUILD
downloadaur-65484b888f5ac41007cda20fba75c41f3072a139.tar.gz
Initial import from old AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee33975f9eb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=dri2proto
+pkgname=$_pkgname-git
+pkgver=2.8.3.gddc1287
+pkgrel=1
+pkgdesc="X11 DRI extension wire protocol."
+url="https://wiki.freedesktop.org/xorg/"
+arch=("any")
+license=("custom")
+makedepends=("git" "xorg-util-macros")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git://git.freedesktop.org/git/xorg/proto/$_pkgname")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s|dri2proto.||g;s|-|.|g"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}