summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Brill2021-11-09 10:55:09 +0100
committerChristoph Brill2021-11-09 10:55:09 +0100
commit36fbfd5e3ea1e75c5f48a1e5ccc0a2fe680628d0 (patch)
treecd83af5312e4d3ed4e13287d8ea3368bdfe7d7bc /PKGBUILD
downloadaur-36fbfd5e3ea1e75c5f48a1e5ccc0a2fe680628d0.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01e1ed81b8cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Christoph Brill <aur@christophbrill.de>
+pkgname=driftwood
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="lookup whether a private key is used for things like TLS or as a GitHub SSH key"
+arch=('i686' 'x86_64')
+url="https://github.com/trufflesecurity/driftwood"
+license=('Apache')
+depends=()
+optdepends=()
+makedepends=(
+ 'go'
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/trufflesecurity/driftwood/archive/v${pkgver}.tar.gz")
+sha256sums=('0de16944692454c9ff82bc1f3b74f24be94737fa0f21f4546ac31a3ecfb85a11')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ go build
+ mkdir "$pkgdir"/usr/bin -p
+ cp ${pkgname} "$pkgdir"/usr/bin
+}