summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryochananmarqos2019-07-27 18:53:49 -0600
committeryochananmarqos2019-07-27 18:53:49 -0600
commitd1426c9d1191fd3637840a0d2862506986589401 (patch)
tree2832ee48a58b49fe0463ef336fbeaf8526964d5b /PKGBUILD
parent1490b942a5182cfe458dd091b915ae5d400783e3 (diff)
downloadaur-d1426c9d1191fd3637840a0d2862506986589401.tar.gz
reverted back to 1.258 stable release version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8043ceb66b4c..18879d6f63bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
pkgname=('drill-search-cli' 'drill-search-gtk')
pkgbase=drill-search
-pkgver=1.277
+pkgver=1.258
pkgrel=1
arch=('x86_64')
-url="https://www.drill.santamorena.me/"
+url="https://www.drill.santamorena.me"
license=('GPL2')
makedepends=('git' 'dmd' 'dub')
_dubv=("1.0.3" #datefmt
@@ -17,7 +17,7 @@ source=("$pkgbase-$pkgver.tar.gz::https://github.com/yatima1460/Drill/archive/$p
"$pkgbase-gtk.svg"
"datefmt::git+https://github.com/dhasenan/datefmt.git#tag=v${_dubv[0]}"
"gtkd::git+https://github.com/gtkd-developers/GtkD.git#tag=v${_dubv[1]}")
-sha256sums=('450b5b5f91bba7a9c16a8479b59c94ef9eb812d8b271346dccf9ccf60f7eaac2'
+sha256sums=('09fad3a9e2db20be67ab60ea6990a5a50ba41044f164364cf5ec4d06aa521bbf'
'b875f928546aee7855cb1db9afc8ab3f1a8a34d43de5bbd62f7076d7ba9f3917'
'5bafb37baf608a3168abba2ab9ea174a1d0f0472f52d3222ea0a05957c997c50'
'cbfbcebb2957223eaa9c915780a5d0ac47c1fac70b7944f49e8ffcfe740edc53'
@@ -39,14 +39,14 @@ build() {
--cache=local `# ensure dub stays outside the users home directory`\
--parallel `# runs multiple compiler instances in parallel, if possible`\
--force `# Forces a recompilation even if the target is up to date`\
- --build=release \
+ --build=release
cd .. && cd GTK
dub build \
--cache=local `# ensure dub stays outside the users home directory`\
--parallel `# Runs multiple compiler instances in parallel, if possible`\
--force `# Forces a recompilation even if the target is up to date:`\
- --build=release \
+ --build=release
# remove local dependencies from search path so dub won't find them
# again later
@@ -63,8 +63,10 @@ package_drill-search-cli() {
cd "Drill-$pkgver/Source/Frontend/CLI"
install -d $pkgdir/{opt/$pkgname,usr/bin}
- cp -r Build/Drill-CLI-linux-$arch-release/Assets $pkgdir/opt/$pkgname
- install -Dm755 Build/Drill-CLI-linux-$arch-release/$pkgname $pkgdir/opt/$pkgname/$pkgname
+ cp -r Build/Drill-CLI-linux-$arch-release/Assets \
+ $pkgdir/opt/$pkgname
+ install -Dm755 Build/Drill-CLI-linux-$arch-release/$pkgname \
+ $pkgdir/opt/$pkgname/$pkgname
install -Dm755 $srcdir/$pkgbase $pkgdir/usr/bin/$pkgname
echo "/opt/$pkgname/$pkgname" "\$@" >> $pkgdir/usr/bin/$pkgname
}
@@ -75,10 +77,14 @@ package_drill-search-gtk() {
cd "Drill-$pkgver/Source/Frontend/GTK"
install -d $pkgdir/{opt/$pkgname,usr/bin}
- cp -r Build/Drill-GTK-linux-$arch-release/Assets $pkgdir/opt/$pkgname
- install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
- install -Dm644 $srcdir/$pkgname.svg $pkgdir/usr/share/pixmaps/$pkgname.svg
- install -Dm755 Build/Drill-GTK-linux-$arch-release/$pkgname $pkgdir/opt/$pkgname/$pkgname
+ cp -r Build/Drill-GTK-linux-$arch-release/Assets \
+ $pkgdir/opt/$pkgname
+ install -Dm644 $srcdir/$pkgname.desktop \
+ $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.svg \
+ $pkgdir/usr/share/pixmaps/$pkgname.svg
+ install -Dm755 Build/Drill-GTK-linux-$arch-release/$pkgname \
+ $pkgdir/opt/$pkgname/$pkgname
install -Dm755 $srcdir/$pkgbase $pkgdir/usr/bin/$pkgname
echo "/opt/$pkgname/$pkgname" "\$@" >> $pkgdir/usr/bin/$pkgname
}