summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorToolybird2020-05-19 18:07:04 +1000
committerToolybird2020-05-19 18:07:04 +1000
commit0af3d7e38e65c001c377d8a02175cbb56084316c (patch)
treed429051f9d7cef6f6da32cc26acf8f7389fb512f /PKGBUILD
downloadaur-driverctl.tar.gz
newpkg: driverctl 0.111-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..deecba8ec591
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Toolybird <toolybird at tuta dot io>
+
+pkgname=driverctl
+pkgver=0.111
+pkgrel=1
+pkgdesc="Device driver control utility"
+arch=('any')
+url="https://gitlab.com/driverctl/driverctl"
+license=('LGPL2.1')
+depends=('bash')
+optdepends=('bash-completion: bash completion')
+source=("https://gitlab.com/driverctl/driverctl/-/archive/$pkgver/driverctl-$pkgver.tar.bz2")
+sha256sums=('31a077a4bf620cb1026d849c53b58697a5812be48d07118aca70f6b8cd3d8d8e')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" SBINDIR=/usr/bin install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}