summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNahuel Morata2019-09-15 14:04:45 -0300
committerNahuel Morata2019-09-15 14:04:45 -0300
commitf7dff406f1bf62a4adbe57ba797cc92fce64792e (patch)
tree72f7903a761842d42f9f9b94074bf45e8462b843 /PKGBUILD
parentfc6d337efa00e663fa56666a0235fb7ccea02fb7 (diff)
downloadaur-f7dff406f1bf62a4adbe57ba797cc92fce64792e.tar.gz
Arreglo a version de git real
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41ec6177a22c..2357ea67bfd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nahuel Morata <nahuelmorata@gmail.com>
pkgname=drivesync-git
_origname="drivesync"
-pkgver=1.2.0
+pkgver=1.4.0.r0.g1124fc6
pkgrel=1
pkgdesc="A command line utility that synchronizes your Google Drive files with a local folder on your machine"
arch=('any')
@@ -10,17 +10,20 @@ license=('MIT')
depends=("ruby")
provides=("drivesync")
install=.INSTALL
-source=("https://github.com/MStadlmeier/$_origname/archive/$pkgver.tar.gz")
-md5sums=("821d5a4da22cd473290727a7ea470f0b")
-sha256sums=("fb32c3d89171ac4680e02d9325e042728baad40b74bcaff8c77742b0958d8388")
+source=("$pkgname::git+https://github.com/MStadlmeier/drivesync.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
gem install bundler
- tar xf "$pkgver.tar.gz"
}
build() {
- cd "$_origname-$pkgver"
+ cd "$pkgname"
~/.gem/ruby/$(ls ~/.gem/ruby | tail -n 1)/bin/bundle install
}
@@ -29,5 +32,5 @@ package() {
echo "alias drivesync='ruby /opt/drivesync/drivesync.rb'" >> ~/.bashrc
fi
- mv -T $_origname-$pkgver /tmp/drivesync
+ mv -T $pkgname /tmp/drivesync
}