summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsekret2015-11-29 21:17:20 +0100
committersekret2015-11-29 21:17:20 +0100
commit686b196da81fe557fc0e471464335f37a418d3e8 (patch)
tree0708a80be3016abd8a6d84ccd03b03226cfa1dcc /PKGBUILD
downloadaur-drmdecrypt-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4ca41ed9530
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+_pkgname=drmdecrypt
+pkgname=$_pkgname-git
+pkgver=1.0.r13.ge7f479f
+pkgrel=1
+pkgdesc="DRM decrypting tool for Samsung TVs"
+arch=('i686' 'x86_64')
+url="https://github.com/decke/drmdecrypt"
+license=('GPL2')
+depends=('glibc')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}
+
+# vim:set ts=2 sw=2 et: