summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoel Teichroeb2015-06-08 16:23:41 -0700
committerJoel Teichroeb2015-06-08 16:23:41 -0700
commite1d50cbe707a427910a444e769711af602e7e368 (patch)
tree0c3bc46b8857f11bf15c85bc1d873ee71b30978b /PKGBUILD
downloadaur-e1d50cbe707a427910a444e769711af602e7e368.tar.gz
Add dropbox-cli
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5507439135d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Joel Teichroeb <joel@teichroeb.net>
+# Contributor: Matthias Maennich < arch .at. maennich.net >
+# Contributor: bruce < b_a_g99 .at. hotmail.com >
+# Contributor: carstene1ns <arch carsten-teibes de>
+
+pkgname=dropbox-cli
+pkgver=2.10.0
+pkgrel=4
+pkgdesc='Command line interface for dropbox'
+arch=('any')
+url='http://www.dropbox.com'
+license=('GPL')
+install='dropbox-cli.install'
+depends=('python2' 'dropbox')
+makedepends=("patch")
+source=("https://linux.dropbox.com/packages/dropbox.py"
+ "$pkgname-arch.patch")
+md5sums=('50c2aefa89822bafd5f67d3678843dc3'
+ '0cb7114774490c31e7cc10f86692ac70')
+
+build(){
+ mkdir -p "$srcdir/build"
+ cp -L "$srcdir/dropbox.py" "$srcdir/build/"
+ cd "$srcdir/build"
+ patch -i "$srcdir/$pkgname-arch.patch"
+}
+
+package() {
+ install -D -m 755 "$srcdir/build/dropbox.py" "$pkgdir/usr/bin/dropbox-cli"
+}