summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsekret2015-06-09 19:59:54 +0200
committersekret2015-06-09 19:59:54 +0200
commit6d0ef449e6e1b793fd1b69bd4aad8d884954decf (patch)
tree80ce428c4578913882f493fa96b18bbd3c6af2e8 /PKGBUILD
downloadaur-6d0ef449e6e1b793fd1b69bd4aad8d884954decf.tar.gz
initial AUR4 import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05317f0dbcf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+_pkgname=drumgizmo
+pkgname=$_pkgname-git
+pkgver=0.9.8.1.r20.g2699cb7
+pkgrel=1
+pkgdesc="an open source cross-platform drum plugin and stand-alone application (lv2)"
+arch=('i686' 'x86_64')
+url="http://www.drumgizmo.org"
+license=('GPL')
+groups=('lv2-plugins')
+depends=('libsmf' 'jack' 'libao' 'qt4')
+makedepends=('git' 'cppunit')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+http://git.drumgizmo.org/drumgizmo.git"
+ 'hugin::git+http://git.oftal.dk/hugin.git')
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ git submodule init
+ #git config submodule.mysubmodule.url $srcdir/mysubmodule
+ git config submodule.hugin.git.oftal.dk $srcdir/hugin
+ git submodule update
+ # hackish, but I don't want to clone hugin with every build
+ #rmdir hugin
+ #ln -sf "$srcdir/hugin" hugin
+ ./autogen.sh
+}
+
+build() {
+ cd "$_pkgname"
+ ./configure --prefix=/usr \
+ --enable-lv2 \
+ --enable-cli \
+ --enable-editor \
+ --enable-static=no \
+ --with-resample
+ make
+}
+
+#check() {
+# cd "$_pkgname"
+# make check
+#}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: