summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsekret2016-02-08 13:27:10 +0100
committersekret2016-02-08 13:27:10 +0100
commitc7712b9879415aad3e7f39d40bad28be748825d2 (patch)
tree65aaa286e6478a7c69168f5fd24503be404415e7 /PKGBUILD
parent864d2bfdf867a435df0c2cf9fca6fd8c26ba8fa3 (diff)
downloadaur-c7712b9879415aad3e7f39d40bad28be748825d2.tar.gz
updated dependencies, makedependencies and configure options
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c772127bf138..9d285c01c8ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
_pkgname=drumgizmo
pkgname=$_pkgname-git
-pkgver=0.9.8.1.r22.ga611e1e
+pkgver=0.9.8.1.r363.g9aa7d52
pkgrel=1
pkgdesc="an open source cross-platform drum plugin and stand-alone application (lv2)"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://www.drumgizmo.org"
license=('GPL')
groups=('lv2-plugins')
-depends=('libsmf' 'jack' 'libao' 'qt4' 'zita-resampler')
-makedepends=('git' 'cppunit')
+depends=('libsmf' 'jack' 'zita-resampler' 'libx11')
+makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+http://git.drumgizmo.org/drumgizmo.git"
@@ -33,19 +33,10 @@ prepare() {
build() {
cd "$_pkgname"
./configure --prefix=/usr \
- --enable-lv2 \
- --enable-cli \
- --enable-editor \
- --enable-static=no \
- --with-resample
+ --enable-lv2
make
}
-#check() {
-# cd "$_pkgname"
-# make check
-#}
-
package() {
cd "$_pkgname"
make DESTDIR="$pkgdir/" install