summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantinos2017-06-17 19:20:33 +0300
committerKonstantinos2017-06-17 19:20:33 +0300
commit8b6432cbaf54467e56869a4b0e5aff8cecf49008 (patch)
tree07e47e88d64b7e2a6467fbceaa563cb465c148f6 /PKGBUILD
downloadaur-drumstick-svn.tar.gz
useful commit message
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0f53e472570
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+_pkgname=drumstick
+pkgname=${_pkgname}-svn
+pkgver=20170510.341
+pkgrel=1
+pkgdesc="MIDI libraries for Qt5/C++. (SVN version)"
+arch=('x86_64' 'i686')
+url="http://drumstick.sourceforge.net"
+license=('GPL')
+depends=('fluidsynth' 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info' 'qt5-svg')
+makedepends=('cmake' 'doxygen' 'docbook-xsl' 'subversion')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("svn+https://svn.code.sf.net/p/${_pkgname}/code/trunk")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd trunk
+ svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
+}
+
+build() {
+ cd trunk
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=release \
+ -DLIB_SUFFIX=
+ make
+}
+
+package() {
+ cd trunk
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: