summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Auditor2016-01-22 09:15:21 +0100
committerStefan Auditor2016-01-22 09:15:21 +0100
commit095514f3cefd62565dd77dd24cef51744a8198d1 (patch)
tree715f8d6e272a36ab3f5889b1e9da30d0dc6e7c6b /PKGBUILD
parent7730a578f75a8f529f3ef7f1cd3d59924490aabe (diff)
downloadaur-095514f3cefd62565dd77dd24cef51744a8198d1.tar.gz
Change checkout paths
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36c217da67ea..d4637c24cd6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=drupalconsole
pkgname=${_pkgname}-git
-pkgver=0.10.5.r12.geaeb48a
+pkgver=0.10.5.r31.gdd3012c
pkgrel=1
pkgdesc="The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation."
arch=('any')
@@ -12,22 +12,22 @@ license=('GPL')
depends=('php')
makedepends=("php-box" "php-composer" "git")
install=("${_pkgname}.install")
-source=("${_pkgname}-${pkgver}"::"git+https://github.com/hechoendrupal/DrupalConsole.git")
+source=("${_pkgname}"::"git+https://github.com/hechoendrupal/DrupalConsole.git")
sha512sums=('SKIP')
pkgver() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}"
ulimit -n 3072
php /usr/bin/composer install --no-dev
php -d phar.readonly=Off /usr/bin/php-box build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}"
install -D -m755 "drupal.phar" "${pkgdir}/usr/bin/drupal"
}