summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Häggqvist2015-07-30 01:19:01 +0200
committerVictor Häggqvist2015-07-30 01:19:01 +0200
commitb9ccb352e4900207dc67d746221105102cd26095 (patch)
treeb1ca3def2413e0dde01d9284045e2b385e484135 /PKGBUILD
downloadaur-b9ccb352e4900207dc67d746221105102cd26095.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..820aefe6c798
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Victor Häggqvist <aur@snilius.com>
+
+_pkgname=drupalconsole
+pkgname=drupalconsole-git
+pkgver=0.7.15.r81.g4e2a2b8
+pkgrel=1
+pkgdesc="The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation."
+url="http://drupalconsole.com/"
+license=('MIT')
+arch=('any')
+depends=('php' 'php-composer')
+provides=('drupalconsole')
+conflicts=('drupalconsole')
+source=($pkgname::git+https://github.com/hechoendrupal/DrupalConsole.git)
+sha512sums=('SKIP')
+install="$_pkgname.install"
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ composer install
+}
+
+package() {
+ install -dm755 "$pkgdir/opt/$_pkgname/"
+ cp -a "$srcdir/$pkgname/." "$pkgdir/opt/$_pkgname"
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s "$pkgdir/opt/$_pkgname/bin/console" "$pkgdir/usr/bin/drupal"
+
+}
+
+#package() {
+#j cd "$srcdir/rainbowstream-${pkgver}/"
+ # python setup.py install --root="$pkgdir/" --optimize=1
+#}
+
+# vim: ts=2 sts=2 sw=2 et ft=sh