summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoredombek2023-03-11 10:23:14 +0300
committeredombek2023-03-11 10:23:14 +0300
commit1718ddb63b37bb07ff26397cbb8083e96124fc92 (patch)
tree2f6cadf41ed4a0c21ac455f018aaa2dab6b2658c /PKGBUILD
parent8b98192a153a53dbcb2aaecd61c4af9457fb2851 (diff)
downloadaur-1718ddb63b37bb07ff26397cbb8083e96124fc92.tar.gz
fixes and version up
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 10 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c484fe4ff43..11d5a51a8cda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,27 @@
+# Maintainer: Evgeniy Dombek <edombek@yandex.ru>
# Maintainer: Yigit Dallilar <yigit.dallilar at gmail dot com>
pkgname=ds9
-pkgver=8.3
-pkgrel=5
+pkgver=8.4.1
+pkgrel=6
pkgdesc="SAOImage DS9: Astronomical Data Visualization Application"
url="http://hea-www.harvard.edu/RD/ds9/"
arch=('x86_64')
license=('GPL2')
+provides=(ds9)
conflicts=(ds9-bin)
-depends=()
+depends=(libx11 libxslt libxml2 libxft tcl zip)
options=(!strip)
-makedepends=(libx11 libxslt libxml2 libxft tcl zip)
+makedepends=(gcc make)
replaces=()
backup=()
source=("https://github.com/SAOImageDS9/SAOImageDS9/archive/v${pkgver}.tar.gz"
- "ds9.desktop"
- "ds9.png"
- "format-security.patch")
-md5sums=('1c3784c93d63ee1c194b0480f17d3f93'
- 'f1738e4ec665ae9afd1b65b86e6a07f1'
- '9297d5738f5f462831075c483dc785d5'
- '64ebd4c1e03b45fc682b692046028f1d')
+ "ds9.desktop")
+md5sums=('d47bfa849596e76e69838050f09ba9ad'
+ 'f1738e4ec665ae9afd1b65b86e6a07f1')
-prepare() {
- cd ${srcdir}/SAOImageDS9-${pkgver}
- patch --strip=1 < ../format-security.patch
-}
-
build() {
- LDFLAGS="-lm $LDFLAGS"
- echo $LDFLAGS
cd ${srcdir}/SAOImageDS9-${pkgver}
unix/configure
make
@@ -39,7 +30,7 @@ build() {
package() {
install -Dm644 ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
- install -Dm644 ${pkgname}.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
+ install -Dm644 ${srcdir}/SAOImageDS9-${pkgver}/ds9/doc/sun.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
cd ${srcdir}/SAOImageDS9-${pkgver}
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE