summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFredrik Strandin2015-02-16 21:24:24 +0100
committerFredrik Strandin2015-02-16 21:24:24 +0100
commitdf3102e655cbde7aa3cac84a568acd1d86437b97 (patch)
treefd6da80ba0c779da8ef4af871affc8a8b8b9b283 /PKGBUILD
downloadaur-df3102e655cbde7aa3cac84a568acd1d86437b97.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fa1db46499e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Fredrik Strandin <fredrik@strandin.name>
+
+pkgname="dspdfviewer"
+pkgver=1.11
+pkgrel=1
+pkgdesc="Viewer for latex-beamer presentations that are built with the «show notes on second screen»-option"
+arch=('i686' 'x86_64')
+url="https://github.com/dannyedel/dspdfviewer"
+license=('GPL')
+depends=('boost-libs' 'poppler-qt4')
+makedepends=('cmake' 'boost')
+conflicts=('dspdfviewer-git')
+source=("https://github.com/dannyedel/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('39c97a91fa1006ec43c2d75a7be3190d')
+sha256sums=('366ed816158a5d618a464e3fe255a37f78365e3a640b6fe69187d990f46948fd')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX="/usr/" \
+ -DSYSCONFDIR="/etc" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DDSPDFVIEWER_VERSION="${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: