summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRowan Lewis2015-06-09 10:54:26 +0200
committerRowan Lewis2015-06-09 10:54:26 +0200
commita2cb4aedd2e4794afc079afdb66367a089760c46 (patch)
treec9819e55833eee5e06e28f6f782b05f7556e6389 /PKGBUILD
downloadaur-a2cb4aedd2e4794afc079afdb66367a089760c46.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81b0b322fd39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Rowan Lewis <rl@nbsp.io>
+
+pkgname=dsplight
+pkgver=1.0
+pkgrel=1
+pkgdesc="A very simple application that changes MacBooks' with Intel graphics display backlight level."
+arch=("x86_64")
+url="https://github.com/psychoticmeow/dsplight/"
+license=('BSD')
+source=("https://github.com/psychoticmeow/$pkgname/archive/v${pkgver}.zip")
+md5sums=('952f752e3399a41b6784a8adbadf528f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" PREFIX=/usr/ install
+ chmod 4755 "$pkgdir/usr/bin/$pkgname"
+}