summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastiaan de Schaetze2019-05-05 19:14:47 +0200
committerSebastiaan de Schaetze2019-05-05 19:14:47 +0200
commit6d976b7e88b1ae765e5c20c21eb53ac9fa22cb06 (patch)
treeb91e9273bcbfb7907f5ab2711230698e06895fd3 /PKGBUILD
downloadaur-6d976b7e88b1ae765e5c20c21eb53ac9fa22cb06.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afd9d07fce8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Sebastiaan de Schaetzen <sebastiaan.de.schaetzen@gmail.com>
+pkgname=dsweep
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="A minesweeper clone for the terminal written in D"
+arch=(any)
+url="https://github.com/seeseemelk/dsweep"
+license=('MIT')
+makedepends=(dub d-compiler)
+source=("https://github.com/seeseemelk/dsweep/archive/v${pkgver}.tar.gz")
+md5sums=('3577f474c3b253ca8948a7a90a5cff40')
+
+build() {
+ cd "$pkgname-$pkgver"
+ dub build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ dub test
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m755 dsweep "$pkgdir/usr/bin/$pkgname"
+}