summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaoyang Zhang2021-10-23 12:07:21 +0800
committerGaoyang Zhang2021-10-23 12:07:21 +0800
commitd2ee18dce832010620a307b9f95a1570cfb183bb (patch)
tree36b020b29f9ca1ef7f13b55abf43770ce1e46d06 /PKGBUILD
parentd83de1c762408c6d3697c34736be1dfd56949691 (diff)
downloadaur-d2ee18dce832010620a307b9f95a1570cfb183bb.tar.gz
chore: only run tests on necessary parts of the code
Signed-off-by: Gaoyang Zhang <gy@blurgy.xyz>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d79fca82cff5..b307af7421a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gaoyang Zhang <gy@blurgy.xyz>
pkgname=dt-cli
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Syncing dotfiles and more"
arch=("any")
@@ -29,12 +29,12 @@ validpgpkeys=()
build() {
cd "dt-$pkgver"
- cargo build --bin=dt-cli --release --all-features
+ cargo build --bin=dt-cli --release --all-features --locked
}
check() {
cd "dt-$pkgver"
- cargo test --release --all-features
+ cargo test --bin=dt-cli --lib=dt-core --all-features --locked
}
package() {