summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCraig Barnes2021-05-09 12:00:38 +0100
committerCraig Barnes2021-05-09 12:00:38 +0100
commitd86d5fbbf06b44dae95ea2aeedba155e231a4add (patch)
treef71890c5c12ff61beb4128c0d98f5aa26605bafc /PKGBUILD
parent91b3e0f9a7027ef28fd592f9962c90aa7b04a61b (diff)
downloadaur-d86d5fbbf06b44dae95ea2aeedba155e231a4add.tar.gz
Add some optdepends and also install bash completion script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a4694ff1976..ad8f9ea34973 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,18 @@
# Maintainer: Craig Barnes <craigbarnes@protonmail.com>
pkgname='dte'
pkgver='1.10'
-pkgrel='1'
+pkgrel='2'
pkgdesc='A small, configurable console text editor'
url='https://craigbarnes.gitlab.io/dte/'
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
license=('GPL2')
depends=('glibc')
+optdepends=(
+ 'ctags: for generating "tags" files for the tag command'
+ 'git: for the builtin git-grep and git-open aliases'
+ 'fzf: for the builtin git-open alias'
+)
+makedepends=(bash-completion)
source=("https://craigbarnes.gitlab.io/dist/dte/dte-$pkgver.tar.gz")
sha256sums=('db62aab235764f735adc8378f796d6474596582b7dae357e0bddf31304189800')
@@ -15,7 +21,12 @@ build() {
make V=1
}
+check() {
+ cd "$pkgname-$pkgver"
+ make check V=1
+}
+
package() {
cd "$pkgname-$pkgver"
- make install V=1 prefix=/usr DESTDIR="$pkgdir"
+ make install install-bash-completion V=1 prefix=/usr DESTDIR="$pkgdir"
}