summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBailey Kasin2018-07-31 00:25:36 -0700
committerBailey Kasin2018-07-31 00:25:36 -0700
commit871def8f9e03942585cb6c805f07acbbe170fdb2 (patch)
tree4d616b9c7a5b88dc10dc1ab389d1807a7dcdd3ce /PKGBUILD
downloadaur-871def8f9e03942585cb6c805f07acbbe170fdb2.tar.gz
DTrace-Utils version 1.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00136c99c40c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Bailey Kasin <bailey@gingertechnology.net>
+
+pkgname=dtrace-utils
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="DTrace-utils contains the Userspace portion of the DTrace port to Linux"
+arch=('x86_64')
+url="https://github.com/oracle/dtrace-utils"
+license=('UPL')
+depends=(
+ 'elfutils'
+ 'zlib'
+ 'sudo'
+ 'git'
+)
+makedepends=(
+ 'glibc'
+ 'flex'
+ 'bison'
+ 'libelf'
+ 'kernel-uek-devel'
+ 'dtrace-utils-devel'
+)
+source=(
+ 'https://github.com/oracle/dtrace-utils/archive/1.0.2.tar.gz'
+ 'third_arg.patch'
+)
+md5sums=(
+ 'c344a52504d1124b2e2188dda344b43e'
+ '48b69bae8daf29415f45c3a22c3f4d7f'
+)
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p0 < "${srcdir}/third_arg.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir ../linux
+ cp -r /usr/src/kernels/4.14.35-1818.0.9.el7uek.x86_64/include/uapi/linux/dtrace ../linux/
+ make HDRPREFIX=../
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sudo make install
+}