summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2023-09-20 21:46:01 -0400
committerChris Severance2023-09-20 21:46:01 -0400
commitc924af371827249deda05514a87ab4d0bf933d09 (patch)
treeeb0d7840cc758808ec25852cb044607d3667f9bb /PKGBUILD
parent56cd8a68f62d9cd7fd39575f4185338d087c0f0a (diff)
downloadaur-c924af371827249deda05514a87ab4d0bf933d09.tar.gz
autu: Update to 8.6.3.40040-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 27 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a5f6e991953..e42b1b0e39d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
-# Maintainer: ghost64 <michael at corrigan dot xyz>
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Previous Maintainer: ghost64 <michael at corrigan dot xyz>
# Previous Maintainer: uzerus <szymonscholz at gmail dot com>
-# Previous Maintainer: Matthew Gamble
+# Previous Maintainer: Matthew Gamble
-pkgname=duck
-pkgver=7.6.2.33520
-pkgrel=1
-pkgdesc="Cyberduck CLI"
-arch=('x86_64' 'i686')
+pkgname='duck'
+pkgver='8.6.3.40040'
+pkgrel='1'
+pkgdesc='Cyberduck CLI file transfer client for WebDAV HTTPS FTP-SSL SFTP Azure Backblaze B2 Google Cloud Drive Amazon S3 OpenStack Swift Rackspace DRACOON Dropbox OneDrive SharePoint'
+arch=('x86_64')
license=('GPL')
-options=(!strip)
-url="https://duck.sh/"
+options=('!strip')
+url='https://duck.sh/'
depends=(
- 'java-runtime'
-# 'java-environment-common'
- 'pango'
- 'libxi'
- 'libnet'
- 'libglvnd'
- 'gdk-pixbuf2'
+ 'java-runtime'
+# 'java-environment-common'
+ 'pango'
+ 'libxi'
+ 'libnet'
+ 'libglvnd'
+ 'gdk-pixbuf2'
)
-
-source_x86_64=("https://repo.cyberduck.io/stable/x86_64/$pkgname-$pkgver.$CARCH.rpm")
-source_i686=("https://repo.cyberduck.io/stable/i386/$pkgname-$pkgver.$CARCH.rpm")
+source=("https://dist.duck.sh/${pkgname}-${pkgver}-1.${CARCH}.rpm")
+#source=("https://repo.cyberduck.io/stable/x86_64/$pkgname-$pkgver-1.$CARCH.rpm")
+md5sums=('73f945033d05edc5c4d6e99c7f6524db')
+sha256sums=('f12afad669ba7e14dedb6af42fbcf76ba7cb3ebc5d1412474155b96a7b7a87d1')
package() {
- cp -R opt "${pkgdir}/opt"
- chmod -R go-w "${pkgdir}/opt/duck"
- mkdir -p "${pkgdir}/usr/bin"
- ln -s /opt/duck/duck "${pkgdir}/usr/bin/duck"
- install -Dm644 "${pkgdir}/opt/duck/duck.desktop" "${pkgdir}/usr/share/applications/duck.desktop"
+ cp -pR 'opt' "${pkgdir}/opt"
+ chmod -R 'go-w' "${pkgdir}/opt/duck"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s '/opt/duck/bin/duck' "${pkgdir}/usr/bin/duck"
+ # GUI not available for Linux. CLI only.
+ #install -Dm644 "${pkgdir}/opt/duck/lib/duck-duck.desktop" "${pkgdir}/usr/share/applications/duck.desktop"
}
-sha256sums_x86_64=('612aae66bef284f199ffc1dc9facc206fedc5a62a500750238f0967fa1507382')
-sha256sums_i686=('8a95c65d10a9171f5ac1ed7f50e4c139d6df8080b8665821befd4d920c0eb92a')