summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-11-16 08:13:46 +0000
committerGeorge Rawlinson2021-11-16 08:13:46 +0000
commit24e4bd364aaa68b0d4a89a524ecc6afc4285dd5b (patch)
treeffea45a287e21eff6b4f09a33155c9c8dde01cae /PKGBUILD
parenteae022012f9c156c99dda7577421a64049b55be3 (diff)
downloadaur-24e4bd364aaa68b0d4a89a524ecc6afc4285dd5b.tar.gz
upgpkg: duckdb 0.3.1-1
* New upstream release. * Include rest server.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd70d7373ad9..918da54dfa6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgbase=duckdb
pkgname=('duckdb' 'python-duckdb')
-pkgver=0.3.0
-pkgrel=2
+pkgver=0.3.1
+pkgrel=1
pkgdesc="A high-performance analytical database system"
arch=('x86_64')
url="https://duckdb.org"
license=('MIT')
depends=('gcc-libs' 'openssl')
makedepends=('git' 'cmake' 'python-setuptools' 'pybind11' 'python-numpy' 'python-pandas' 'libutf8proc' 'python-pip' 'python-wheel' 'python-setuptools-scm')
-_commit='46a0fc50aa00ac019aee2157cf3382b85993f728'
+_commit='88aa81c6b1b851c538145e6431ea766a6e0ef435'
source=("$pkgbase::git+https://github.com/duckdb/duckdb.git#commit=$_commit")
b2sums=('SKIP')
@@ -36,7 +36,6 @@ prepare() {
-DBUILD_PARQUET_EXTENSION=1 \
-DBUILD_BENCHMARKS=1 \
-DBUILD_REST=1 \
- -DBUILD_TPCE=1 \
-DAMALGAMATION_BUILD=1
}
@@ -50,6 +49,9 @@ package_duckdb() {
conflicts=('duckdb-git')
DESTDIR="$pkgdir" cmake --install build
+ # rest server
+ install -vDm755 -t "$pkgdir/usr/bin" build/tools/rest/duckdb_rest_server
+
# sqlite wrapper
install -vDm755 -t "$pkgdir/usr/lib" build/tools/sqlite3_api_wrapper/libsqlite3_api_wrapper.so