summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreugene2023-08-30 01:22:57 +0000
committereugene2023-08-30 01:22:57 +0000
commit9a45a1c586d3a7f107d9161679d607cf71b0780f (patch)
treecc8edf0b9796a8187608edfd522cecf0a2eedd2b /PKGBUILD
parent1496b8c29e3eeddecd9f174627eb0b6385abcfb9 (diff)
downloadaur-9a45a1c586d3a7f107d9161679d607cf71b0780f.tar.gz
quick and dirty type error fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c08f3a80e43..6470ea625164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,6 +53,10 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ grep -RlZ 'uint[[:digit:]]\+_t' "$srcdir/$_pkgname"/dep/reshadefx | xargs -0 sed -i '1 i\#include <stdint.h>'
+}
+
build() {
cmake -B build -S duckstation \
-DCMAKE_BUILD_TYPE=Release \
@@ -66,14 +70,13 @@ build() {
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-DBUILD_NOGUI_FRONTEND=OFF \
-DBUILD_QT_FRONTEND=ON \
- -DUSE_DRMKMS=OFF \
-DUSE_EGL=ON \
-DUSE_SDL2=ON \
-DUSE_WAYLAND=ON \
-DUSE_X11=ON \
-G Ninja \
-Wno-dev
- ninja -C build -v
+ cmake --build build --parallel
}
package() {