summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrevel2016-05-29 06:54:15 +0200
committerrevel2016-05-29 06:54:15 +0200
commit47775e9a9e7c9aee5815b410c779312e48616010 (patch)
tree3bcd5645efdad21cdbecb2d9acac77ec2ca3b172 /PKGBUILD
parenta6e50834a7fcda5f5790174bac1ec2df43157ada (diff)
downloadaur-47775e9a9e7c9aee5815b410c779312e48616010.tar.gz
- fixes compilation errors, thanks to doskoi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 206df24bbec8..2a27ff397512 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=duma
pkgver=2.5.15
-pkgrel=2
+pkgrel=3
pkgdesc='Multi-platform memory debugging library (Detect Unintended Memory Access)'
arch=('i686' 'x86_64')
url='http://duma.sourceforge.net/'
@@ -15,6 +15,11 @@ source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/${pkgna
md5sums=('fe630c69cbaa39caf225a3d9ed2fda1f')
sha256sums=('baaf794854e3093ad1bddadbfb8ad4b220a7117d70359ee216bd59e353734e17')
+prepare() {
+ cd "${pkgname}_${_pkgver}"
+ sed -i 's/CPPFLAGS=/\0-std=gnu++98 /g' GNUmakefile
+}
+
build() {
cd "${pkgname}_${_pkgver}"
make