summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorugjka2018-03-03 21:20:48 +0200
committerugjka2018-03-03 21:20:48 +0200
commitfd0851fed5502e4b8086fb3107b3c3ad7cc3be2b (patch)
tree1c0c20620ddeae45d7d0ad818a4f937e3b6fcba1 /PKGBUILD
downloadaur-fd0851fed5502e4b8086fb3107b3c3ad7cc3be2b.tar.gz
add
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9224e480ef82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: ugjka <ugis.germanis@gmail.com>
+
+_pkgname=dumb-mp3-streamer
+pkgname="$_pkgname-git"
+pkgver=20180303.fb4bcb2
+pkgrel=1
+pkgdesc='Stream mp3 from stdin'
+arch=('x86_64')
+url="https://github.com/ugjka/${_pkgname}"
+license=('MIT')
+makedepends=('go' 'go-tools' 'git' 'make')
+source=("$_pkgname"::"git+http://github.com/ugjka/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+build(){
+ cd $_pkgname
+ make prefix=/usr all
+}
+
+package(){
+ cd $_pkgname
+ make prefix="${pkgdir}"/usr install
+ make clean
+}