summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMisaka135142024-01-28 17:51:03 +0800
committerMisaka135142024-01-28 17:51:03 +0800
commitd905084b89fbbec5b8f656806977e3cbc0357ca3 (patch)
treea8da1310d03601cd4361c03452f01064b1d6d9cc /PKGBUILD
parent95058b24e6ac3a28880b59f60f5dab0b38ca0477 (diff)
downloadaur-dump1090-git.tar.gz
Fix namcap validation error
The LICENSE file will be included in PKGBUILD files until: - antirez/dump1090#34 - antirez/dump1090#61 - antirez/dump1090#164 are fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 32 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf40680f8e1d..9b37d3980155 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=dump1090-git
_pkgname=${pkgname%-git}
pkgver=r386.bff92c4
-pkgrel=4
+pkgrel=5
pkgdesc="A simple Mode S decoder for RTLSDR devices. MalcolmRobb fork."
arch=('x86_64' 'aarch64')
url="https://github.com/MalcolmRobb/dump1090"
@@ -46,5 +46,35 @@ package() {
install -Dm755 "view1090" "$pkgdir/usr/bin/view1090"
install -dm755 "$pkgdir/usr/share/$_pkgname"
cp -dpr --no-preserve=ownership public_html testfiles tools "$pkgdir/usr/share/$_pkgname/"
- install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md TODO
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md TODO
+ install -Dm644 "/dev/stdin" "$pkgdir/usr/share/licenses/$pkgname/LICENSE" << "EOF"
+Copyright (c) 2013, Salvatore Sanfilippo
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification,
+are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+3. Neither the name of the copyright holder nor the names of its contributors
+ may be used to endorse or promote products derived from this software without
+ specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+EOF
+
}