summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmanuel Duss2023-04-11 22:18:11 +0200
committerEmanuel Duss2023-04-11 22:18:11 +0200
commit78e3f399628069cbdcf004df96cedd164b9ca568 (patch)
tree0baadbf3ae3d9e89c77f8f76cc43f713d34bebd9 /PKGBUILD
parent04d6659945973e73903befe972a48bcca4e11a5b (diff)
downloadaur-78e3f399628069cbdcf004df96cedd164b9ca568.tar.gz
Update cfg, glibc in dependencies and respect *FLAGS by Štěpán
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 279bc5b2b5f3..af3c171525ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Emanuel Duss <emanuel.duss@gmail.com>
# Contributor: Nicolas Martyanoff <khaelin@gmail.com>
pkgname=dumpasn1
-pkgver=20220916
+pkgver=20230322
pkgrel=1
pkgdesc="ASN.1 analyze tool"
url="http://www.cs.auckland.ac.nz/~pgut001"
@@ -10,15 +10,15 @@ source=('https://www.cs.auckland.ac.nz/~pgut001/dumpasn1.c'
'https://www.cs.auckland.ac.nz/~pgut001/dumpasn1.cfg'
'LICENSE')
sha256sums=('8ce8fdbf2e9b11d410b0ab4e44a6b3f89c27080113f051ec1054d230e050a0b8'
- '1d02cfea8fa556281aed3911f96db517a50017eaaaded562fe6683d008bd1fac'
+ 'ed1eaafb0ad865b97738dfe0b0e5d602c76dc0cde4c0cee4cdcdd11c28f480e5'
'f58dfb06633792773b4e539666f0fac52eb44acf29619175d073b146e22785e4')
arch=('i686' 'x86_64')
-depends=()
+depends=(glibc)
build() {
cd "${srcdir}"
- gcc -o dumpasn1 dumpasn1.c
+ gcc $CPPFLAGS $CFLAGS $LDFLAGS -o dumpasn1 dumpasn1.c
}
package(){