summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhoffer.joshua2017-08-02 12:26:30 -0600
committerhoffer.joshua2017-08-02 12:26:30 -0600
commitd2eef4c61e3091bafee31a5a7f5dcadae7ddc648 (patch)
tree9ed1b2518e2d9b82b149ae2f68491154137ec54c /PKGBUILD
downloadaur-d2eef4c61e3091bafee31a5a7f5dcadae7ddc648.tar.gz
Initial PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32c9d3acdc6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Josh Hoffer < hoffer dot joshua at gmail dot com >
+pkgname=dune-functions
+pkgver=2.5.1
+pkgrel=1
+pkgdesc='Abstractions for functions and discrete function space bases'
+groups=('dune')
+url='https://dune-project.org/modules/dune-functions/index.html'
+arch=('any')
+license=('custom')
+source=("git+https://gitlab.dune-project.org/staging/${pkgname}.git#tag=v${pkgver}")
+makedepends=('cmake' "dune-common=${pkgver}" "dune-typetree" "dune-localfunctions" "dune-grid")
+md5sums=('SKIP')
+
+package() {
+ dunecontrol --only=${pkgname} make install DESTDIR="${pkgdir}"
+ install -m644 -D ${pkgname}/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ find "${pkgdir}" -type d -empty -delete
+}
+
+build() {
+ CMAKE_FLAGS='-DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -fPIC -DBUILD_SHARED_LIBS:BOOL=OFF' \
+ dunecontrol configure --enabled-shared
+ dunecontrol make
+ }
+