summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames An2017-01-26 01:12:57 -0500
committerJames An2017-01-26 01:12:57 -0500
commit93f686d4eccba939a78cac6973db5522c44551f3 (patch)
tree904fafa530b48066e2e4feeec7c5309faf41d5f6 /PKGBUILD
downloadaur-93f686d4eccba939a78cac6973db5522c44551f3.tar.gz
Initial commit with working PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dc4121f901c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=dupd-git
+_pkgname=${pkgname%-git}
+pkgver=1.3.r83.ged1888f
+pkgrel=1
+pkgdesc="CLI utility to find duplicate files"
+arch=('i686' 'x86_64' 'any')
+url="http://www.virkki.com/$_pkgname"
+license=('GPL3')
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("$_pkgname"::"git+https://github.com/jvirkki/$_pkgname.git"
+ "libbloom"::"git+https://github.com/jvirkki/libbloom.git"
+ test.patch)
+md5sums=('SKIP'
+ 'SKIP'
+ '5228e790f359376d51a9348cb72092eb')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$_pkgname"
+
+ patch -p1 -i ../test.patch
+}
+
+build() {
+ cd libbloom && make && cd ..
+ cd "$_pkgname"
+
+ make
+}
+
+check() {
+ cd "$_pkgname"
+ mv tests/{,~}test.72
+
+ make test
+}
+
+package() {
+ cd "$_pkgname"
+
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}