summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik Schwan2020-05-17 04:51:13 +0200
committerFrederik Schwan2020-05-17 04:51:13 +0200
commit24a21c376b63fe91e7e71194869d286aa8fb85f6 (patch)
tree7793176ed02f2acbdd6009971fb60b7816efd798 /PKGBUILD
parent79ea03c604658a6d3efe3e6aa92f2bf237b7f0a7 (diff)
downloadaur-24a21c376b63fe91e7e71194869d286aa8fb85f6.tar.gz
review by anthraxx
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b0775802bbe..fa4bf9d6dccd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Frederik Schwan <freswa at archlinux dot org>
pkgname=duperemove-git
-pkgver=636.128acd9
-pkgrel=2
+pkgver=0.11.beta4.r62.g128acd9
+pkgrel=1
pkgdesc="Btrfs extent deduplication utility"
arch=('x86_64' 'i686')
url="https://github.com/markfasheh/duperemove"
@@ -10,12 +10,13 @@ license=('GPL')
depends=('glib2' 'sqlite')
makedepends=('git')
provides=('duperemove')
-source=("${pkgname}"::'git://github.com/markfasheh/duperemove.git#branch=master')
+conflicts=('duperemove')
+source=(${pkgname}::'git+https://github.com/markfasheh/duperemove.git#branch=master')
b2sums=('SKIP')
pkgver() {
cd ${pkgname}
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ echo $(git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')
}
build() {