summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSanskritFritz2016-01-27 12:04:33 +0100
committerSanskritFritz2016-01-27 12:04:33 +0100
commitba70e9529d594c8c0b06e1f39623f4d578ff83d4 (patch)
tree5a1cf715e29857be47705e669181c362b2082172 /PKGBUILD
downloadaur-ba70e9529d594c8c0b06e1f39623f4d578ff83d4.tar.gz
Upstream version 5.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f987c18d5fff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=dupfiles
+pkgver=5.8
+pkgrel=1
+pkgdesc="Find and hardlink duplicate files."
+arch=('any')
+url="http://liw.fi/dupfiles/"
+license=('GPL')
+depends=('python2')
+source=("http://code.liw.fi/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.orig.tar.xz")
+
+build() {
+ cd "$pkgname-$pkgver"
+ sed -i -e 's/python/python2/' setup.py
+ sed -i -e 's/python/python2/' dupfiles
+ python2 setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+md5sums=('63156d0aa8720b7368b7dacee9319ee5')