summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIan Young2021-03-01 22:26:10 -0600
committerIan Young2021-03-01 22:29:33 -0600
commit7287cd08b52115eaa4c6a3f8c9e63d1c1b6ec513 (patch)
tree2b0acddf93eeb4d98acce209559bbe71b897732c /PKGBUILD
parent9e658000abf120a74b858b641755405ea7708118 (diff)
downloadaur-7287cd08b52115eaa4c6a3f8c9e63d1c1b6ec513.tar.gz
Add module flag to other steps as well
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e87e060e7312..804972303d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,13 +30,13 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- GOPATH="$srcdir/$pkgname-$pkgver/$pkgname" go build -x
+ GO111MODULE=auto GOPATH="$srcdir/$pkgname-$pkgver/$pkgname" go build -x
}
check() {
cd "$pkgname-$pkgver/$pkgname"
- GOPATH="$srcdir/$pkgname-$pkgver/$pkgname" go test -v -x
+ GO111MODULE=auto GOPATH="$srcdir/$pkgname-$pkgver/$pkgname" go test -v -x
}
package() {