summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIan Young2021-03-01 22:24:27 -0600
committerIan Young2021-03-01 22:24:49 -0600
commit9e658000abf120a74b858b641755405ea7708118 (patch)
tree82ac9252a9f1e939e723681e610be12b3740d923 /PKGBUILD
parenta0c796c0d8050d61de19b6197859ca7a1f0e0d9c (diff)
downloadaur-9e658000abf120a74b858b641755405ea7708118.tar.gz
Adding flags recommended by Go package guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93c5e7f2ca15..e87e060e7312 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=duplicacy
pkgver=2.7.2
-pkgrel=2
+pkgrel=3
pkgdesc="A new generation cloud backup tool based on lock-free deduplication"
arch=('x86_64' 'i686')
url="https://duplicacy.com/"
@@ -25,7 +25,11 @@ prepare() {
build() {
cd "$pkgname-$pkgver/$pkgname"
-
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
GOPATH="$srcdir/$pkgname-$pkgver/$pkgname" go build -x
}