summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoey Dumont2017-10-25 11:02:16 -0400
committerJoey Dumont2017-10-25 11:02:16 -0400
commit08ac29be293c0a965fc76ecd602ee1df53bb1895 (patch)
tree34a27aeb11852ff99f49191fd1608670efa32750 /PKGBUILD
parent019edfc9448e275be710122bae0ce3f0dddfe012 (diff)
downloadaur-08ac29be293c0a965fc76ecd602ee1df53bb1895.tar.gz
Added dupliati-cli alias, as described in https://github.com/duplicati/duplicati/wiki/Headless-installation-on-Debian-or-Ubuntu.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index beb7ab7791b3..eab3d4747085 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=duplicati-latest
pkgver=2.0.2.12
-pkgrel=1
+pkgrel=2
_date=2017-10-20
_branch=canary
pkgdesc='A free backup client that securely stores encrypted, incremental, compressed backups on cloud storage services and remote file servers'
@@ -14,11 +14,13 @@ install=duplicati.install
source=(https://github.com/duplicati/duplicati/releases/download/v${pkgver}-${pkgver}_${_branch}_${_date}/duplicati-${pkgver}_${_branch}_${_date}.zip
duplicati-user.service
duplicati.service
- duplicati.sysusers)
+ duplicati.sysusers
+ duplicati-cli)
sha256sums=('0ee644e2e65856ab59b2e1b39cf6a45c207132a84967a4d3ff70b243edff9b68'
'ec25b25d0e331ddfb90940555068aa941c3d5dfaf858cffb6c75e810175c9d27'
'087db7ce97c4180006c2708d49024c0393f48f83ea2ce8b0b6354fffa554ece9'
- 'b9389b399467f3e02aa8e76bb98f6efbca1166fbc4d0bdf939493f8403462959')
+ 'b9389b399467f3e02aa8e76bb98f6efbca1166fbc4d0bdf939493f8403462959'
+ 'f6f903ca443935314afeab4cd2e46cf4bef7c5fb1e81c2d95f670f0993774ce5')
arch=('i686' 'x86_64')
depends=('gtk-sharp-2' 'mono')
@@ -33,4 +35,7 @@ package() {
rm *.zip
mkdir -p "${pkgdir}/opt/duplicati-latest"
cp -r . "${pkgdir}/opt/duplicati-latest"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ install -D -m755 duplicati-cli "${pkgdir}/usr/bin"
}