summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2020-07-21 17:21:48 +0200
committerKr1ss2020-07-21 17:21:48 +0200
commita8121d54261a53c830052b2afe873d41d6accea1 (patch)
treeeea018d9aa064a744769a863361ccb199e99c032 /PKGBUILD
parent16db3d9922e06c2ddc2aa9e8702a0aac57b9ee5d (diff)
downloadaur-a8121d54261a53c830052b2afe873d41d6accea1.tar.gz
depend on community/opencv, not on the PyPI wheel
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b296828ac8a..38972afa6100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
pkgname=dupliseek-git
+
+epoch=1
pkgver() { git -C "${pkgname%-git}" describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'; }
-pkgver=0.0.3.r3.340563c
+pkgver=0.0.3.r24.4faf56e
pkgrel=1
-epoch=1
pkgdesc='Duplicate image finder written in Python/Qt5'
arch=('x86_64')
@@ -15,7 +16,7 @@ license=('MIT')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-depends=('python-pyqt5' 'python-numpy' 'python-imutils' 'python-opencv-python')
+depends=('python-pyqt5' 'python-numpy' 'python-imutils' 'opencv')
makedepends=('git' 'python-setuptools' 'python-pip')
source=("git+$url.git")
@@ -25,6 +26,7 @@ prepare() {
cd "${pkgname%-git}"
sed -i "s|\(/usr/share/\)icons\(/${pkgname%-git}\)|\1pixmaps\2.png|;
s|^\(Categories=.*\)|\1\;Utility|" "${pkgname%-git}.desktop"
+ sed -i "s|opencv-python|opencv|" setup.py
}
build() {