summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDylan Delgado2021-10-17 22:38:54 -0400
committerDylan Delgado2021-10-17 22:38:54 -0400
commit38ab467131c96585b6ad86bf60273b8831526628 (patch)
treee3b46af9bc01a5a790d068319bd5797b2b37f83d /PKGBUILD
downloadaur-dusk-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eddb867e47ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=dusk-git
+_pkgname=dusk
+pkgver=r467.4cce9d6
+pkgrel=1
+pkgdesc="Just another fork of dwm"
+url="https://github.com/bakkeby/dusk"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('git' 'libx11' 'libxcb' 'libxinerama' 'libxft' 'imlib2' 'yajl')
+optdepends=('dmenu: default application launcher'
+ 'st: default terminal')
+source=(git+https://github.com/bakkeby/dusk.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make config.h
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ #make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm755 dusk "$pkgdir/usr/bin/dusk"
+ install -Dm755 duskc "$pkgdir/usr/bin/duskc"
+ install -Dm644 dusk.1 "$pkgdir/usr/share/man/man1/dusk.1"
+ sed -i "s/VERSION/1.0/g" "$pkgdir/usr/share/man/man1/dusk.1"
+ install -Dm644 dusk.desktop "$pkgdir/usr/share/xsessions/dusk.desktop"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}