summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122024-02-18 11:47:16 +0100
committerwillemw122024-02-18 11:47:16 +0100
commitdc2974e9caa87ddbf1a3f10acde4427bafcc0c1c (patch)
tree25122434703ffa39778b8403676a2f44141aaf13 /PKGBUILD
parent7dbd463fc277d9bb88d54315e74598e66a8b1233 (diff)
downloadaur-dutree-git.tar.gz
Set "target" inside package source folder
Change description.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aedb36bf0407..261dd3946144 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=dutree-git
pkgver=0.2.18.r0.g44e877d
pkgrel=1
-pkgdesc='A tool to analyze file system usage written in Rust'
+pkgdesc='Tool to analyze file system usage written in Rust'
arch=(x86_64)
url=https://github.com/nachoparker/dutree
license=(GPL3)
@@ -20,23 +20,15 @@ pkgver() {
}
prepare() {
- cd $pkgname
- export RUSTUP_TOOLCHAIN=stable
- cargo fetch --locked --target="$CARCH-unknown-linux-gnu"
+ RUSTUP_TOOLCHAIN=stable cargo fetch --locked --manifest-path=$pkgname/Cargo.toml --target="$CARCH-unknown-linux-gnu"
}
build() {
- cd $pkgname
- export RUSTUP_TOOLCHAIN=stable
- export CARGO_TARGET_DIR=target
- cargo build --frozen --release --all-features
+ RUSTUP_TOOLCHAIN=stable cargo build --release --manifest-path=$pkgname/Cargo.toml --target-dir=$pkgname/target --all-features
}
check() {
- cd $pkgname
- export RUSTUP_TOOLCHAIN=stable
- export CARGO_TARGET_DIR=target
- cargo test --frozen --all-features
+ RUSTUP_TOOLCHAIN=stable cargo test --release --manifest-path=$pkgname/Cargo.toml --target-dir=$pkgname/target
}
package() {