summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMauro Santos2016-06-22 13:32:58 +0100
committerMauro Santos2016-06-22 13:32:58 +0100
commit6120a5c99b1a1f25457cdebf48241949c37e3cdd (patch)
tree956e4953a53965a7eaddd771a1821e553d77ea5f /PKGBUILD
parent9dd2b80cd14cb438a045b079f80c408b68be8d8a (diff)
downloadaur-6120a5c99b1a1f25457cdebf48241949c37e3cdd.tar.gz
Fix compilation with kernel 4.6.x
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 914cedd25151..15cb4a15766c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,11 +17,13 @@ provides=('dvb-usb-rtl2832u')
source=('dvb-usb-rtl2832u.patch::https://github.com/Xtrend-Official/meta-xtrend/raw/master/recipes-bsp/linux/linux-etxx00/dvb-usb-rtl2832.patch'
'Makefile'
'dvb-usb-rtl28xxu.conf'
- 'linux42.patch')
+ 'linux42.patch'
+ 'rtl2832-get-parameters.patch')
md5sums=('263f5060ff7ef969ecaad1494700230a'
'b91ef30d49fc0e7d8e76b39c98cf3ff6'
'063be4e255e010899574fc3cdec67120'
- 'bc75fc1f5a9030d6545c66642612ef3d')
+ 'bc75fc1f5a9030d6545c66642612ef3d'
+ '4e5b15eee3f6206a415fb441f799d566')
PKGEXT='.pkg.tar'
_extramodules="extramodules-$(uname -r | cut -f-2 -d.)-$(uname -r | cut -f3- -d-)"
@@ -42,6 +44,7 @@ build() {
## Patches go here ##
patch -p1 < "$srcdir/linux42.patch"
+ patch -p1 < "$srcdir/rtl2832-get-parameters.patch"
# Build module
export KBUILD_SRC="/usr/lib/modules/${_kernver}/build"