summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorflan_suse2023-01-14 10:15:25 -0500
committerflan_suse2023-01-14 10:15:25 -0500
commit3c0c9435188f77b246bca276f7db692e69a3713a (patch)
treed27efccbe3342d1cacdec25bb37c7586e54aa03d /PKGBUILD
parent58b2a621699089b5740126aad225d7a112ece670 (diff)
downloadaur-dvdisaster.tar.gz
PKGBUILD improvements based on suggestions from user C2D6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2355f99e1d64..d9ab825da5f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
# Maintainer: fitu996 <fitu996 _at_ gmail _dot_ com>
# Maintainer: flan_suse <windows2linux_AT_zoho_DOT_com>
# Contributor: Eric BĂ©langer <eric@archlinux.org>
+# Contributor: C2D6@aur (PKGBUILD improvements)
+
+# NOTE: Previous versions of this PKGBUILD contained an unused signature file.
+# If you wish you validate the source file against its signature,
+# please import the developer's public key (E3AFE70396CCC0D9E5D8381CB0DBCA7D64F770B2),
+# and use their signed file (.gpg) found on the upstream website (https://dvdisaster.jcea.es/index.html).
pkgname=dvdisaster
pkgver=0.79.10
-pkgrel=1
+pkgrel=2
provides=('dvdisaster')
-pkgdesc="Provides a margin of safety against data loss on newly created ISO, CD, DVD, and BDR media caused by aging or scratches"
+pkgdesc="Provides a margin of safety against data loss on newly created ISO, CD, DVD, BDR, and M-Disc media caused by aging or scratches"
arch=('x86_64')
url="https://dvdisaster.jcea.es"
license=('GPL')
depends=('gtk2')
options=('!makeflags')
-source=(${pkgname}-${pkgver}.tar.bz2::${url}/downloads/${pkgname}-${pkgver}.tar.bz2
- ${pkgname}-${pkgver}.tar.bz2.gpg::${url}/downloads/${pkgname}-${pkgver}.tar.bz2.gpg)
-sha1sums=('848f6dea242de90201df3eabf445a5825131ebc6'
- '5b0378d3130c600f8f7a1eb4b603cb2fca82bc71')
-validpgpkeys=('12B31535AF903ADE9E73BA7E5A590EFEF5F6C46C')
-
-prepare() {
- cd ${pkgname}-${pkgver}
- # Modify provided .desktop shortcut to point to dvdisaster.png rather than dvdisaster48.png
- sed -i 's/dvdisaster48/dvdisaster/' contrib/dvdisaster.desktop
-}
+source=(${pkgname}-${pkgver}.tar.bz2::${url}/downloads/${pkgname}-${pkgver}.tar.bz2)
+# Upstream only publishes an MD5 hash, which is why MD5 is specfically used in this checksum array
+md5sums=('e913b8375a2bd41a55df7f53379f8d0d')
build() {
export CFLAGS="$CFLAGS -fcommon"
@@ -40,8 +38,9 @@ package() {
make BUILDROOT="${pkgdir}" install
# Remove unnecessary uninstaller script
rm -f "${pkgdir}/usr/bin/dvdisaster-uninstall.sh"
+ # Copy .desktop file to standard applications directory
install -D -m 644 contrib/dvdisaster.desktop "${pkgdir}/usr/share/applications/dvdisaster.desktop"
- # Rename all .png icons to strip their resolution from their names, and place them in the proper standard directories
+ # Rename all .png icons to strip their resolution from their names, and place them in the proper standard icon subdirectories
for i in 16 24 32 48 64 ; do
install -D -m 644 contrib/dvdisaster${i}.png "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/dvdisaster.png"
done