summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuke Horwell2022-07-31 21:22:36 +0100
committerLuke Horwell2022-07-31 21:22:36 +0100
commit5711d24ffed4da5e9d5c16176a18002f49e46f07 (patch)
treeae4c8f4590dcab40182d0d9d56f7cbae3ddbc917 /PKGBUILD
parent954188648f2beff3da0ce92c71574f6a52077c76 (diff)
downloadaur-5711d24ffed4da5e9d5c16176a18002f49e46f07.tar.gz
Release 1.5
While the version is now 1.5, the tag on GitHub is 'v1.5-release'
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b215f9b3b19f..78f2145ea52c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Luke Horwell <code (at) horwell (dot) me>
pkgname=('dvr-scan')
-pkgver=1.4.1
+pkgver=1.5
+_tagver=1.5-release
pkgrel=1
pkgdesc="Tool for extracting scenes with motion from security camera/DVR footage."
arch=('any')
url="https://github.com/Breakthrough/DVR-Scan"
license=('BSD')
-depends=('python-numpy' 'python-tqdm' 'python-opencv' 'qt5-base' 'fmt')
-makedepends=('python-setuptools' 'python-pytest-runner')
-source=("https://github.com/Breakthrough/DVR-Scan/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('86cf496b8f6acfce3c112270481fdf03df61563dd5e4af73b50d063dce097710')
+depends=('python-numpy' 'python-tqdm' 'python-opencv' 'python-scenedetect' 'qt5-base' 'fmt')
+makedepends=('python-setuptools')
+source=("https://github.com/Breakthrough/DVR-Scan/archive/refs/tags/v$_tagver.tar.gz")
+sha256sums=('c0c5a819320e0ef4b0c3cb20658a9c86772939c13a776055cd386a95de87047f')
package() {
- cd "DVR-Scan-$pkgver"
+ cd "DVR-Scan-$_tagver"
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}