summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevin J. Pohly2021-05-27 09:13:24 -0500
committerDevin J. Pohly2021-05-27 09:13:24 -0500
commit17ac73abc67fe92c6d31706dc0068b9ea415b8e7 (patch)
tree7766534426f155cfe9cf3630e31b10f8cb7ec0a8 /PKGBUILD
parent59c8657051f427a4e5e91d0f99f77cd75129b3f3 (diff)
downloadaur-17ac73abc67fe92c6d31706dc0068b9ea415b8e7.tar.gz
add XWayland optdepend, don't sum config.h
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88940bebff05..75f4b0faa27b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
pkgname=dwl
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)"
arch=('x86_64')
url="https://github.com/djpohly/dwl"
license=('GPL')
depends=('wlroots>=0.13')
makedepends=('wayland-protocols')
+optdepends=('xorg-xwayland: for XWayland support')
source=("https://github.com/djpohly/$pkgname/archive/v$pkgver.tar.gz"
config.h)
sha256sums=('4c65ba86608adc0d37414ebfaf814957d3349518e44f3cc6f50f5f3bd827c150'
- '0bf53ab668252bf63b25e1b3ea76ace85c0dd3cd49e16168e85a3b49f4a3c708')
+ 'SKIP')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
cp "$srcdir/config.h" config.h
+ # Uncomment to compile with XWayland support
+ #sed -i -e '/-DXWAYLAND/s/^#//' config.mk
}
build() {