summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArian2023-09-18 13:34:40 -0700
committerArian2023-09-18 13:34:40 -0700
commitdec7dea56574b7bf5e94be06fa5bca45ffd5ea04 (patch)
treec97255bcaec6b6c488a483b15d7c14975ff40fa6 /PKGBUILD
downloadaur-dwl-guile-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f25408e2c13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Arian-D
+pkgname=dwl-guile-git
+pkgdesc="Dynamic tiling Wayland compositor configurable in Guile Scheme, based on dwl and libguile - now with a REPL!"
+pkgver=2.0.1
+pkgrel=1
+arch=("x86_64" "aarch64")
+url="https://github.com/engstrand-config/dwl-guile"
+license=('GPL')
+depends=('wlroots>=0.16')
+makedepends=('wayland-protocols')
+optdepends=('xorg-xwayland: for XWayland support')
+source=("git+https://github.com/engstrand-config/dwl-guile")
+sha256sums=('SKIP')
+
+build() {
+ # Uncomment to compile with XWayland support
+ # sed -i -e '/-DXWAYLAND/s/^#//' config.mk
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make PREFIX="$pkgdir/usr/" install
+} \ No newline at end of file