summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSuper Mario2020-10-11 16:58:53 +0000
committerSuper Mario2020-10-11 16:58:53 +0000
commit121604b0d61b272df7b0e9a9cd038e156df3b54a (patch)
tree0680f0ff0c5419ebd8d2460392e3457fc09afbb3 /PKGBUILD
parent9c4edb887e879ffc8ee78cb178b43a750f450405 (diff)
downloadaur-121604b0d61b272df7b0e9a9cd038e156df3b54a.tar.gz
Reconstructed the entire package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 20 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf0f6d3a8760..c52b02028c93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,43 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# The following guidelines are specific to BZR, GIT, HG and SVN packages.
-# Other VCS sources are not natively supported by makepkg yet.
-
-# Maintainer: Your Name <youremail@domain.com>
-pkgname=dwm-supermario9590-git # '-bzr', '-git', '-hg' or '-svn'
+# Maintainer: Anish Vundela <anishreddyvundela@gmail.com>
+pkgname=dwm-supermario9590-git
+_pkgname=dwm
pkgver=6.2
pkgrel=1
-pkgdesc="My custom build of dwm"
-arch=('i686' 'x86_64')
-url="https://gitlab.com/supermario9590/dwm-supermario9590.git"
+pkgdesc="My custom build of DWM"
+arch=(x86_64 i686)
+url="https://gitlab.com/supermario9590/dwm-supermario9590"
license=('MIT')
groups=()
depends=(libx11 libxinerama libxft nerd-fonts-mononoki ttf-symbola freetype2 st dmenu emacs)
-makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
-provides=("dwm")
-conflicts=("dwm")
+makedepends=('git')
+provides=(dwm)
+conflicts=(dwm)
replaces=()
backup=()
options=()
install=
-source=("git+$url")
+source=('dwm::git+https://git.suckless.org/dwm')
noextract=()
md5sums=('SKIP')
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
-
pkgver() {
- cd "$srcdir/dwm-supermario9590"
+ cd "$srcdir/${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${_pkgname}"
+ patch -p1 -i "../../dwm-supermario9590.diff"
+}
+
build() {
- cd "$srcdir/dwm-supermario9590"
+ cd "$srcdir/${_pkgname}"
make
}
package() {
- cd "$srcdir/dwm-supermario9590"
+ cd "$srcdir/${_pkgname}"
make PREFIX=/usr DESTDIR="$pkgdir/" install
- install -Dm644 LICENSE $pkgdir/usr/share/licences/$pkgname/LICENCE
- install -Dm644 README.md $pkgdir/usr/share/doc/$pkgname/README.md
+ install -m644 -D LICENCE "$pkgdir/usr/share/licences/$pkgname/LICENCE"
+ install -m644 -D README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}