summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2022-08-21 10:47:36 -0300
committerDaniel Bermond2022-08-21 10:47:36 -0300
commit484a900eac75d5e2e35c11e380d9d84a5935098e (patch)
tree9a75f5674609939d83b2bf0bb920de5ab1cfa257 /PKGBUILD
parent2c557b204c4f89081a7a692d19b30cc490686316 (diff)
downloadaur-484a900eac75d5e2e35c11e380d9d84a5935098e.tar.gz
Change compiler back to gcc to fix build
Now it's giving a build error (at link time) with clang: /usr/bin/ld: error: LLVM gold plugin: call to _ZZN9valptridxIN3dcx6playerEE22check_index_range_sizeINS2_21index_range_exceptionESt4lessEEjPKcjmPKNS2_18array_managed_typeEEN25DXX_ALWAYS_ERROR_FUNCTION33dxx_trap_handle_index_range_errorEv marked "dontcall-error": invalid index used in array subscript It started to build fine with gcc again, as it's currently building without problems when using it.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0116fb20f39..49b2019726ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,14 @@ _music='sc55' # (sc55/opl3) - update checksums if you change
pkgbase=dxx-rebirth-git
pkgname=('d1x-rebirth-git' 'd2x-rebirth-git')
-pkgver=0.60.0.beta2.r1821.g092daecb6
+pkgver=0.60.0.beta2.r2022.g25688635b
pkgrel=1
pkgdesc='A source port of the Descent and Descent 2 engines (git version)'
arch=('x86_64')
url='https://www.dxx-rebirth.com/'
license=('GPL3' 'custom:Parallax')
depends=('glu' 'libgl' 'libpng' 'sdl2' 'sdl2_image' 'sdl2_mixer' 'physfs')
-makedepends=('git' 'scons' 'clang')
+makedepends=('git' 'scons')
source=('git+https://github.com/dxx-rebirth/dxx-rebirth.git'
'https://www.dxx-rebirth.com/download/dxx/res/d1xr-hires.dxa'
"https://www.dxx-rebirth.com/download/dxx/res/d1xr-${_music}-music.dxa"
@@ -49,7 +49,6 @@ build() {
'use_tracker=yes'
'screenshot=png')
- export CXX='clang++'
scons "${_common_opts[@]}" 'd1x=1' 'd2x=0' 'sharepath=/usr/share/d1x-rebirth'
scons "${_common_opts[@]}" 'd1x=0' 'd2x=1' 'sharepath=/usr/share/d2x-rebirth'
}